中国足彩在线

设为中国足彩在线 | 加入收藏 | 学院中国足彩在线
网络安全专栏
当前位置: 中心中国足彩在线 >> 网络安全专栏 >> 正文
网络安全专栏

常见的网络高危漏洞

发布时间: 2019-05-20

[2017.03.07] Struts2 Jakarta插件高危远程代码执行漏洞

漏洞描述:

Apache Struts 2被曝存在远程命令执行漏洞,漏洞编号S2-045CVE编号CVE-2017-5638,在使用基于Jakarta插件的文件上传功能时,有可能存在远程命令执行,导致系统被黑客入侵。

影响版本:

Struts 2.3.5 - Struts 2.3.31

Struts 2.5 - Struts 2.5.10

漏洞等级:

高危

修复建议:

1、升级Struts Struts 2.3.32 Struts 2.5.10.1 版本。

 

[2017.01.12] PHPMailer任意文件读取漏洞

漏洞描述:

PHPMailer是全球最流行邮件发送类,其全球范围内的用户量大约有900万,被诸多开源项目所采用,包括WordPressDrupal1CRMJoomla!等。PHPMailer <= 5.2.21版本存在任意文件读取漏洞(CVE-2017-5223),成功利用该漏洞,可获取服务器中的任意文件内容。

影响版本:

PHPMailer <= 5.2.21

漏洞等级:

高危

修复建议:

1、升级到没有漏洞版本。

 

[2016.10.27] 大华、雄迈(DVR/DVS等)设备存在弱口令漏洞通告

漏洞描述:

Mirai是近期非常热门的僵尸网络,Mirai控制的肉鸡主要是运行着特定armlinux系统的物联网设备,包含安防监控设备,摄像头,路由设备等。

安全指数通过设备指纹进行分析,估算出大华设备(DVR/DVS/NVR/IP Cameras),包含其他OEM厂商,有60万以上的设备存在多组Web弱口令(根据之前安全人员Z-0ne的弱口令的探测结果),并且存在多个命令执行漏洞。雄迈科技设备(DVR/DVS/NVR),包含其他OEM的厂商,在互联网有50万设备存在弱口令。原因为其设备内置的root密码无法更改,并且存在多个口令绕过漏洞。

百度安全将进一步关注被利用设备情况,并对设备IP进行识别,对受影响的设备进行攻击风险标注。

修复建议:

1、升级固件,更改弱口令包含web管理口令。

2、关闭外网开放的端口。

3、若发现本地监听了48101 ,请对遭受攻击状况进行排查。

 

[2016.09.13] MySQL高危代码执行0Day漏洞

漏洞描述:

漏洞编号: CVE-2016-6662CVE-2016-6663,攻击者可以远程和本地利用漏洞ROOT权限执行代码,完全控制MySQL数据库。攻击者仅需有FILE权限即可实现ROOT提权,进而控制服务器。

影响版本:

<=5.7.15

漏洞等级:

高危

修复建议:

10Day漏洞暂无厂商修复方案。临时缓解方案: 确保MySQL配置文件不在mysql用户手中,并建立root权限、不使用的、伪装的my.cnf文件。

 

[2016.08.18] zabbix高危SQL注入漏洞通告

漏洞描述:

zabbix是一个开源的企业级性能监控解决方案。近日,zabbixjsrpcprofileIdx2参数存在insert方式的SQL注入漏洞,攻击者无需授权登陆即可登陆zabbix管理系统,也可通过script等功能轻易直接获取zabbix服务器的操作系统权限。

影响版本:

2.2.x, 3.0.0-3.0.3

漏洞等级:

高危

修复建议:

1、尽快升级到最新版,3.0.4以上版本已修复该漏洞。

 

 

[2016.07.19] HTTPoxy高危CGI环境变量劫持漏洞通告

漏洞描述:

当某个服务在CGI模式或者类似环境中运行时,在请求头部加入PROXY HeaderCGI程序会把http header中的内容写入到环境变量中如HTTP_PROXY字段由于环境变量的变动,可导致服务器向外发起的请求可以被代理,从而监听以及篡改流量。受影响的语言包括: PHPPythonGo等。

影响版本:

漏洞等级:

高危

修复建议:

1、禁用所有请求中的 Proxy Header

[2016.07.14] Drupal多个模块高危远程命令执行漏洞通告

漏洞描述:

DrupalRESTWSCoderWebform Multiple File Upload三个模块存在高危远程代码执行漏洞。

影响版本:

Webform Multifile 7.x-1.x7.x-1.3

Coder module 7.x-1.x7.x-1.2

Coder module 7.x-2.x7.x-2.5

RESTful Web Services 7.x-2.x7.x-2.5

RESTful Web Services 7.x-1.x7.x-1.6

漏洞等级:

高危

修复建议:

1、升级模块至最新版本。

 

[2016.07.12] WordPress插件Mailpress高危远程命令执行漏洞通告

漏洞描述:

Mailpress是一个比较流行的WordPress邮件插件,由于存在越权调用,在不登陆的情况下,可以调用系统某些方法,造成远程命令执行。

影响版本:

所有版本,当前最新版本5.4.3

漏洞等级:

高危

修复建议:

1、建议停用此插件。

 

[2016.07.01] phpwind9.x8.7XSS注入以及管理后台脚本注入漏洞通告

漏洞描述:

phpwind近期公布了2处安全漏洞,分别是富文本编辑器发帖的xss注入(受影响版本8.79.X)以及管理后台添加新用户时的脚本注入(受影响版本8.7)。

影响版本:

phpwind 9.x以及8.7,8.7.1

漏洞等级:

高危

修复建议:

1、安装官方最新补丁,官方补丁: http://www.phpwind.net/read/3709782

 

[2016.06.23] Librachive多个高危溢出漏洞通告

漏洞描述:

开源压缩库Librachive存在以下几个漏洞,处理7-Zip文件时发生整数溢出(CVE-2016-4300),处理Mtree文件时缓冲区溢出(CVE-2016-4301)、处理RAR文件时堆溢出(CVE-2016-4302),攻击者可利用这些漏洞在感染的设备上远程执行代码。

影响版本:

Librachive < v3.2.1

漏洞等级:

高危

修复建议:

1、升级到v3.2.1版本。

 

[2016.06.22] OpenSSL中危拒绝服务漏洞(CVE-2016-2177)通告

漏洞描述:

OpenSSL是一种开放源码的SSL实现,用来实现网络通信的高强度加密,现在被广泛地用于各种网络应用程序中。OpenSSL<=1.0.2h版本,堆缓冲区边界检查中未正确使用指针,远程攻击者利用此漏洞可造成拒绝服务。

影响版本:

OpenSSL <= 1.0.2h

漏洞等级:

中危

修复建议:

1、升级到高于1.0.2h版本。

2、安装官方补丁: http://git.openssl.org/?p=openssl.git;a=commit;h=a004e72b95835136d3f1ea90517f706c24c03da7

 

[2016.06.16] Struts2高危远程代码执行(S2-037)漏洞通告

漏洞描述:

Struts 2再曝远程代码执行漏洞S2-037CVE编号CVE-2016-4438。使用REST插件的用户会受到影响。

影响版本:

Struts 2.3.20-2.3.28.1

漏洞等级:

高危

修复建议:

1、升级到2.3.29版本。

 

[2016.06.14] Apache Continuum高危0Day命令执行漏洞通告

漏洞描述:

Apache Continuum持续集成工具,Linux平台版本存在命令执行漏洞,攻击者利用漏洞可执行任意指令。

影响版本:

<= 1.4.2Linux版本)

漏洞等级:

高危

修复建议:

0Day漏洞暂无修复方案。建议添加网站至云观测,及时了解该漏洞的后续情况。

了解更多:

http://www.exploit-db.com/exploits/39945/

 

[2016.06.08] NagiosXI多个高危漏洞通告

漏洞描述:

NagiosXI近期爆出多个漏洞,包括未经身份验证的SQL注入和认证绕过、任意代码执行、特权提升、服务器端请求伪造和帐户劫持。综合利用这些漏洞可以获得root权限远程执行代码。

影响版本:

NagiosXI<= 5.2.7

漏洞等级:

高危

修复建议:

1、升级到最新版本。

 

[2016.06.02] Discuz!X高危SSRF漏洞通告

漏洞描述:

Discuz!X系列远程下载图片功能的文件后缀过滤和文章操作随机密钥算法被绕过导致SSRF漏洞。

影响版本:

< X3.2R20160601

漏洞等级:

高危

修复建议:

1、下载官方补丁升级到最新版本,补丁地址: http://www.discuz.net/forum.php?mod=redirect&goto=findpost&ptid=3570835&pid=29667629

 

[2016.06.01] Struts2高危远程代码执行漏洞通告

漏洞描述:

使用到REST插件的Struts2应用,在开启动态方法调用(DMI)的情况下,会被攻击者利用实现远程代码执行攻击。

影响版本:

Struts2.3.20-2.3.28 2.3.20.32.3.24.32.3.28.1除外)

漏洞等级:

高危

修复建议:

1、禁用动态方法调用(DMI),修改Struts2的配置文件struts.xml,将struts.enable.DynamicMethodInvocation设置为“false”。

2、升级到2.3.20.32.3.24.3或者2.3.28.1版本。

 

[2016.06.01] OGNL高危拒绝服务漏洞通告

漏洞描述:

OGNL缓存投毒漏洞,攻击者可利用该漏洞进行拒绝服务攻击。

影响版本:

Struts2.0.0-2.3.24.1

漏洞等级:

高危

修复建议:

1、升级 OGNL 3.0.12版本以上。

2、升级Struts到最新版。

 

[2016.05.30] ImageMagick再次爆出高危0Day命令执行漏洞通告

漏洞描述:

ImageMagick近日再次爆出远程命令执行漏洞,攻击者利用漏洞可远程实现命令执行,进而可能控制服务器。

影响版本:

<=7.0.1-6

漏洞等级:

高危

修复建议:

1、在官方还没有提供修复方案的情况下,推荐使用百度云加速,目前百度云加速WAF防火墙已可以成功防御该漏洞。

 

[2016.05.24] phpwind高危通讯秘钥安全漏洞通告

漏洞描述:

phpwind9.x 通讯秘钥漏洞可导致前台Getshell

影响版本:

9.x

漏洞等级:

高危

修复建议:

1、安装官方补丁包: http://www.phpwind.net/read/3709549

 

[2016.05.10] Wordpress高危XSS漏洞通告

漏洞描述:

Wordpress官网发布了最新版4.5.2,其中描述了在最新版本中修复了一个之前存在的XSS漏洞。

影响版本:

<4.5.2

漏洞等级:

高危

修复建议:

1、升级到最新的4.5.2版本。

2、使用百度云加速WAF防火墙进行防御。

3、添加网站至云观测,及时了解网站组件突发/0day漏洞。

了解更多:

http://wordpress.org/news/2016/05/wordpress-4-5-2/

[2016.05.09] PHP7 ZipArchive 整型溢出漏洞通告

漏洞描述:

ZipArchivePHP中用于解压缩zip包的类库。有研究人员发现在PHP 7.x环境下使用getFromIndex()getFromName()这两个方法时,通过构造的特殊的zip包可导致PHP程序溢出,攻击者利用该漏洞可造成拒绝服务或执行任意代码。

影响版本:

7.x-7.0.5

漏洞等级:

高危

修复建议:

1、升级PHP至最新版本。

 

[2016.05.09] PHP ligbd图形库溢出漏洞通告

漏洞描述:

libgd是一个开源的图形库,存在整数签名溢出漏洞。攻击者利用漏洞可造成拒绝服务或执行任意代码。

影响版本:

<=2.1.1

漏洞等级:

高危

修复建议:

1、升级PHP至最新版本。

 

[2016.05.05] ImageMagick高危命令执行漏洞通告

漏洞描述:

ImageMagick官方,目前程序存在一处远程命令执行漏洞(CVE-2016-3714),当其处理的上传图片带有攻击代码时,可远程实现远程命令执行,进而可能控制服务器,此漏洞被命名为ImageTragickImageMagick是一款开源图片处理库,支持PHPRubyNodeJSPython等多种语言,使用非常广泛。包括PHP imagickRuby rmagickpaperclip以及NodeJS imagemagick等多个图片处理插件都依赖它运行。可能的影响范围包括各类流行的内容管理系统(CMS)。

影响影响范围:

1、调用ImageMagick的库实现图片处理和渲染的应用。

ImageMagick 为多种语言提供了api,具体可参考http://www.imagemagick.org/script/api.php

2、很多流行的内容管理系统(CMS)使用了ImageMagick ,例如 Wordpress 的图片处理插件已被证实存在远程命令执行的漏洞(Author 及以上权限用户执行)。其他例如MediaWikiphpBBvBulletin 使用了ImageMagick 库生成缩略图,还有一些程序如LyX使用ImageMagick转换图片格式。以上应用可能受到此漏洞影响。

3、如果通过shell 中的convert 命令实现一些图片处理功能,也会受到此漏洞影响。

漏洞等级:

高危

漏洞验证方法:

若系统中安装使用了ImageMagick,本地执行如下命令:

convert 'http://example.com"|ls "-la' out.png

ls -la 命令成功执行,说明存在漏洞。未执行ls 命令,并报错,说明不受影响。

修复建议(临时):

1、由于远程命令执行时,命令代码是包含在图片中上传的,所以在图片上传时需要对图片内容进行检验。

2Linux临时防护方案 : 编辑 /etc/ImageMagick/policy.xml ,在 之间增加以下几行

<policy domain="coder" rights="none" pattern="EPHEMERAL" />

<policy domain="coder" rights="none" pattern="URL" />

<policy domain="coder" rights="none" pattern="HTTPS" />

<policy domain="coder" rights="none" pattern="MVG" />

<policy domain="coder" rights="none" pattern="MSL" />

 

[2016.05.04] OpenSSL缓存溢出,中间人攻击等多个漏洞通告

漏洞描述: OpenSSL在近日更新的版本中,修复了多个漏洞。其中缓存溢出和中间人攻击漏洞最为严重。

影响版本: 1.0.2,1.0.1

漏洞等级: 高危

了解更多: http://www.openssl.org/news/secadv/20160503.txt

漏洞检测地址: http://filippo.io/CVE-2016-2107/(中间人攻击漏洞)

修复建议: 升级至最新版本

 

[2016.04.27] Struts命令执行漏洞更新通告

漏洞描述: 云观测在421日对该漏洞进行过通告,现将该漏洞等级从“中”调整为“高”并对影响版本做了更精确定位。Struts在开启动态方法调用的情况下,会被攻击者实现远程代码执行攻击。

影响版本: 2.3.18-2.3.282.3.20.22.3.24.2除外)

漏洞等级: 高危

了解更多: http://drops.wooyun.org/papers/15430

修复建议: 升级至2.3.20.22.3.242.3.28.1版本

[2016.04.21] Struts命令执行漏洞通告

漏洞描述: Struts在开启动态方法调用或者未进行类型和上传文件内容验证时,可导致远程代码执行漏洞

影响版本: 2.0.0-2.3.282.3.20.22.3.24.2除外)

漏洞等级: 中危

了解更多: http://cwiki.apache.org/confluence/display/WW/S2-031?from=groupmessage&isappinstalled=0http://cwiki.apache.org/confluence/display/WW/S2-032

修复建议: 关闭动态方法调用、进行类型和上传内容验证。或者升级至2.3.20.2,2.3.242.3.28.1版本

 

[2016.04.15] Wordpress多个高危安全漏洞通告

漏洞描述: Wordpress在近日更新的4.5版本中修复了多个安全漏洞,其中SSRF漏洞为百度云安全XTEAM团队贡献详见“了解更多”中链接。XTEAM团队致力于最新的攻防能力的研究和建设,相关成果直接输出给云安全各个产品线。

影响版本: <4.5

漏洞等级: 高危

了解更多: http://codex.wordpress.org/Version_4.5#Security(官网说明)http://xlab.baidu.com/wordpress/(百度XTEAMSSRF漏洞详细说明)

修复建议: 升级至最新4.5版本

 

[2016.03.24] Ubuntu高危tiff漏洞通告

漏洞描述: 攻击者利用该漏洞可能造成拒绝服务攻击

影响版本: Ubuntu 15.10Ubuntu 14.04 LTSUbuntu 12.04 LTS

漏洞等级: 高危

了解更多: http://www.ubuntu.com/usn/usn-2939-1/

修复建议: 下载安装补丁或升级到最新版本

[2016.03.24] glibc高危溢出漏洞通告

漏洞描述: 近日安全人员发现GNU C Library (glibc)中存在严重的溢出安全漏洞,可导致Linux系统被攻击者劫持,CVE编号: CVE-2015-7547

影响版本: 小于2.23

漏洞等级: 高危

了解更多: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-7547

修复建议: 升级到2.23版本

 

[2016.03.16] Squid远程拒绝服务漏洞通告

漏洞描述: 近期Squid官方发布了安全公告,指出修复多个远程拒绝服务漏洞。

影响版本: 3.x-3.5.144.x-4.0.6

漏洞等级: 高危

了解更多: http://www.squid-cache.org/Advisories/SQUID-2016_2.txt

修复建议: 升级到最新版本

 

[2016.03.15] Struts2远程代码执行漏洞通告

漏洞描述: Struts2在近期更新的新版中描述修复了一个可能导致远程代码执行的漏洞。

影响版本: 2.0.0-2.3.24.1

漏洞等级: 高危

了解更多: http://struts.apache.org/docs/s2-029.html

修复建议: 升级到最新版本2.3.25

 

[2016.03.12] BIND多个高危漏洞通告

漏洞描述: 互联网系统协会ISC(Internet Systems Consortium)近日发布BIND存在三个高危拒绝服务安全漏洞,远程攻击者利用上述漏洞,可发起拒绝服务攻击,对互联网上广泛应用 BIND的域名服务器构成安全风险。

影响版本: 9.0.0-9.8.89.9.0-9.9.8-P39.9.3-S1-9.9.8-S59.10.0-9.10.3-P3

漏洞等级: 高危

了解更多: http://kb.isc.org/article/AA-01353http://kb.isc.org/article/AA-01352http://kb.isc.org/article/AA-01351

修复建议: 升级到最新版本

 

[2016.03.02] OpenSSL高危“DROWN ATTACK”安全漏洞通告

漏洞描述: OpenSSL官方在201632日发布了最新安全公告,修复了多个安全漏洞,其中包括一个较为严重的漏洞: 利用SSLv2协议弱点来对TLS进行跨协议攻击“DROWN ATTACK”(CVE-2016-0800)。攻击者能够通过这种攻击方式破解加密通信,获取用户与服务器间的任意通信流量。内容包括但不限于用户名,密码,邮箱以及图片文档等隐私信息。

漏洞影响: 即使服务器和客户端使用TLS协议进行加密,但是如果同时还支持SSLv2,那么仍然会受到“DROWN ATTACK”的影响。如果您的服务器存在如下情形,则受此次漏洞影响:

1,服务器允许SSLv2 协议连接。

2,服务器私钥被应用于其他允许SSLv2 协议连接的服务中,例如应用于SMTPIMAPPOP等。

漏洞等级: 高危

了解更多: http://blog.baidu.com/archives/243

修复建议: 升级至最新版本

 

[2016.03.01] OpenSSL高危DOS漏洞通告

漏洞描述: OpenSSLBIO_printf()存在DOS漏洞,PHPopenssl_pkcs7_encryptApache以及使用BIO_printf()的应用均受影响。

影响版本: <=1.0.2

漏洞等级: 高危

了解更多: http://github.com/openssl/openssl/commit/9cb177301fdab492e4cfef376b28339afe3ef663

修复建议: 升级OpenSSL至最新版本

[2016.02.26] Jenkins高危远程命令执行漏洞通告

漏洞描述: Jenkins使用了XStream库进行反序列化导致对象注入,此漏洞可导致远程命令执行。

影响版本: <1.642.2

漏洞等级: 高危

 

[2016.02.25] Magento高危敏感信息泄露漏洞通告

漏洞描述: Magento存在订单遍历漏洞,利用漏洞可获取敏感信息

影响版本: <=1.9.2.2

漏洞等级: 高危

 

[2016.02.04] Wordpress高危开放重定向和SSRF漏洞通告

漏洞描述: Wordpress官网发布了最新版4.4.2,其中描述了在最新版本中修复了两个之前存在的开放重定向和SSRF漏洞

影响版本: 低于4.4.2

漏洞等级: 高危

 

[2016.01.15] OpenSSH Client信息泄露漏洞通告

漏洞描述: Clientroaming_common.c的函数resend_bytes存在安全漏洞,远程攻击者通过请求传输整个缓冲区,利用此漏洞可获取进程内存的敏感信息。

影响版本: 5.4-7.1

漏洞等级: 高危

了解更多: CVE-2016-0777

修复建议: 目前厂商已修复这个漏洞,请升级到最新版本。

 

 

[2016.01.07] Wordpress高危XSS漏洞通告

漏洞描述: Wordpress官网发布了最新版4.4.1,其中描述了在最新版本中修复了一个之前存在的XSS漏洞

影响版本: 低于4.4.1

漏洞等级: 高危

了解更多: http://wordpress.org/news/2016/01/wordpress-4-4-1-security-and-maintenance-release

修复建议: 升级到最新版本。云观测受影响用户我们将通过邮件和短信通知。

[2015.12.15] Joomla的远程代码执行漏洞通告

漏洞描述: Joomla的远程代码执行漏洞0day

漏洞来源:中国足彩在线_中国足彩网

影响版本: 1.5-3.4.5

漏洞等级: 高危

 

 

[2015.11.15] JbossJava反序列化”远程命令执行漏洞通告

漏洞详情: JbossJava反序列化”远程命令执行漏洞。Jbossjava应用都使用了Apache Commons Collections来构造POP链来进行任意命令执行,有可能被利用造成网站被入侵

影响版本: 全部版本

漏洞等级: 高危

修复建议: 在当前厂商未提供升级或补丁的情况下,请继续关注云观测了解后续厂商修复情况。

备注: 0Day漏洞是指已公布但厂商还没有提供修复方案的漏洞,具有非常高的危险性。

 

 

[2015.11.12] Discuz SSRF漏洞通告

漏洞描述: Discuz X3.2 /source/module/forum/forum_ajax.php文件中的imageurl可被用户控制,虽然限制为图片后缀,但可轻易绕过,导致SSRF漏洞。

漏洞危害: 利用漏洞可访问内网资源,内网扫描,甚至反弹shell(配合其他漏洞)

漏洞来源:中国足彩在线_中国足彩网

影响版本: X3.2

漏洞等级: 高危

 

[2015.10.26] 增加Joomla高危注入漏洞检测

新增功能: Joomla高危注入0Day漏洞检出

漏洞来源:中国足彩在线_中国足彩网

影响版本: 3.2.0-3.4.4

漏洞等级: 高危

[2015.08.31] 增加CmsEasy高危注入漏洞检测

新增功能: CmsEasy无限制报错注入0Day漏洞检出

漏洞来源:中国足彩在线_中国足彩网 wooyun

影响版本: 5.6

漏洞等级: 高危

 

 

[2015.08.21] 增加MetInfo高危注入漏洞检测

新增功能: MetInfo修改管理员密码高危注入0Day漏洞检出

漏洞来源:中国足彩在线_中国足彩网 wooyun

影响版本: 5.3.1

漏洞等级: 高危

 

 

 

[2015.07.27] DEDECMS高危SQL注入漏洞

漏洞详情: DEDECMS mtypes.php SQL注入0Day漏洞,在未开启gpc并同时开启会员注册功能的情况下,攻击者利用漏洞可注入管理员账号

漏洞来源:中国足彩在线_中国足彩网 wooyun

影响版本: 全部版本

漏洞等级: 高危

 

 

[2015.07.22] 增加PHPCMS高危SQL注入漏洞检测

新增功能: PHPCMSV9会员登录中心SQL注入0Day漏洞检出

漏洞来源:中国足彩在线_中国足彩网 wooyun

影响版本: 全部版本

漏洞等级: 高危

备注: 0Day漏洞是指已公布但厂商还没有提供修复方案的漏洞,具有非常高的危险性。

 

[2015.06.26] 增加MetInfo高危信息泄露漏洞检测

新增功能: MetInfo管理员账号密码泄露0Day漏洞检出

漏洞来源:中国足彩在线_中国足彩网 wooyun

影响版本: 全部版本

漏洞等级: 高危

了解更多: http://www.wooyun.org/bugs/wooyun-2015-0121654

修复建议: 在当前厂商未提供升级或补丁的情况下,在后台中删除邮件发送设置。请继续关注云观测了解后续厂商修复情况。

备注: 0Day漏洞是指已公布但厂商还没有提供修复方案的漏洞,具有非常高的危险性。

[2015.06.24] 增加MetInfo高危SQL注入漏洞检测

新增功能: MetInfo order_sql变量覆盖SQL注入高危0Day漏洞检出

漏洞来源:中国足彩在线_中国足彩网 wooyun

影响版本: 全部版本

漏洞等级: 高危

备注: 0Day漏洞是指已公布但厂商还没有提供修复方案的漏洞,具有非常高的危险性。

 

[2015.05.05] 增加Wordpress新漏洞检测

WordPress官方近日发布了新的版本,其中提到修复了一个严重的存储型XSS漏洞。但安全研究团队Klikki Oy发现在新版本(<=4.2)的Wordpress中仍然可以利用该漏洞,并给出了利用方式。其成因是mysql的特性特性引起的。通过此漏洞,攻击者可获取用户cookie以及模拟浏览器正常操作。并且当管理员访问到注入的payload时,结合wordpress后台功能甚至可以getshell。影响wordpress低于4.2.1版本的版本。

修复建议:

1.关闭Wordpress留言/评论功能

2.wordpress升级到最新版本4.2.1